Dualog Drive - Sync

Incident Report for Dualog

Resolved

The issue has been resolved.
Posted Jul 22, 2026 - 11:58 UTC

Investigating

We are currently looking into an issue that may be affecting the performance of Dualog Drive - Sync.
The potential issue only pertains to Sync.
Dualog Drive - Move, as well as other services such as Email, are not impacted.
Posted Jul 22, 2026 - 11:43 UTC
This incident affected: Drive.