Delayed message delivery from vessels

Incident Report for Dualog

Resolved

Mail flow is back to normal and the previous queue has been completely cleared. Thank you for your patience.
Posted Sep 04, 2026 - 14:41 UTC

Monitoring

A fix has been implemented and queued outgoing messages are being cleared quickly. Our team will continue to monitor the situation
Posted Sep 04, 2026 - 13:20 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 04, 2026 - 12:41 UTC

Investigating

One of our outgoing mail servers is seeing a buildup of messages from vessels queued for delivery. Delays in message delivery from vessels may be experienced.

Our team is currently investigating the situation.
Posted Sep 04, 2026 - 10:49 UTC
This incident affected: Email and Automatic File Transfer and Personal Email (Cloud based).