Dualog Portal - Degraded Performance

Incident Report for Dualog

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 07:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2025 - 06:47 UTC

Investigating

The Dualog Portal (apps.dualog.com) is currently experiencing lower performance. We are investigating.

Mail flow and other services are not affected.
Posted Jun 20, 2025 - 06:13 UTC
This incident affected: Dualog Portal (apps.dualog.com).