Dualog services temporarily unavailable

Incident Report for Dualog

Postmortem

Post-Incident Report – Dualog Service Disruption on 28 January 2026

Incident Date: 28 January 2026
Duration: 04:28 to 07:45 UTC
Affected Services: Multiple services (intermittent connectivity)
Status: Resolved

Summary

On 28 January 2026, our infrastructure experienced a network disruption that caused intermittent connectivity issues and reduced service availability between 04:28 and 07:45 UTC. All services were fully restored by 07:45 UTC, and no data was lost.

Impact

A network disruption occurred within our infrastructure, which temporarily impacted service availability during the time window noted above.

  • Services like Mail, Drive, Fetch, and the Dualog Portal experienced intermittent connectivity issues.
  • No data was lost.
  • All services were fully restored by 07:45 UTC.

Root Cause

A pre-existing internal network configuration issue, combined with an unexpected load spike on one of our servers, triggered a cascade effect that temporarily overwhelmed our network capacity. The incident also exposed a latent software bug that only manifested under these specific conditions.

Resolution & Recovery

Our team identified and removed the affected network component, then restored services using an improved configuration. Service stability was fully restored by 07:45 UTC.

Preventive Measures

We have implemented the following improvements to reduce the likelihood of recurrence:

  • Restructured internal network architecture for improved resilience.
  • Reduced the scope of shared network components to minimize cascade risk.
  • Requested increased capacity from our network provider.
  • Initiated a review of our infrastructure to standardize software versions.

Data Integrity

We have no indication of data loss, data leakage, or unauthorized access.

Final Note

At Dualog, service reliability is a top priority. We regret the inconvenience this disruption may have caused and appreciate your patience while we resolved the issue. We remain committed to strengthening the resilience of our platform and sharing transparent updates with our customers.

Posted Jan 30, 2026 - 06:38 UTC

Resolved

This incident has been resolved. Our team will make a full assessment and provide a report within the next 72 hours.
Posted Jan 28, 2026 - 08:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2026 - 07:45 UTC

Update

We are still working on a resolution with the utmost urgency. We are gradually resuming services and monitoring the performance.

No action needed from the ship side. As soon as the services become available, all queued messages and files will be processed. Do expect some delay due to the accumulated backlog.
Posted Jan 28, 2026 - 07:33 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 28, 2026 - 06:13 UTC

Update

We are still experiencing heavy performance fluctuations. No action is required from the ship side, every mail and file is queued up and nothing will be lost.

We are working with our datacenter provider to stabilise the situation.
Posted Jan 28, 2026 - 05:37 UTC

Update

Email exchange may be affected intermittently, our team is continuing to investigate.
Posted Jan 28, 2026 - 05:00 UTC

Update

We are continuing to investigate this issue.
Posted Jan 28, 2026 - 04:31 UTC

Investigating

We are currently investigating this issue.
Posted Jan 28, 2026 - 04:28 UTC
This incident affected: Dualog Portal (apps.dualog.com), Email and Automatic File Transfer, Drive, Endpoint, Personal Email (Cloud based), and Fetch.