Dualog Portal: Slow loading of UI elements

Incident Report for Dualog

Resolved

This incident has been resolved.
Posted May 21, 2026 - 16:06 UTC

Update

The issue has been identified and resolved.
Posted May 21, 2026 - 15:36 UTC

Investigating

The issue has been identified and resolved.
Posted May 21, 2026 - 14:16 UTC
This incident affected: Dualog Portal (apps.dualog.com).