Cloud webmail: Email delivery issues
Incident Report for Dualog
Resolved
This incident has been resolved, and the cloud webmail is fully operational.
Posted Aug 19, 2022 - 13:05 UTC
Investigating
We are currently experiencing issues with our cloud webmail. Emails sent via the cloud webmail may fail to send, and our operations team is currently working on a fix. We will give an update when more information is available.
Posted Aug 19, 2022 - 12:59 UTC
This incident affected: Email and Automatic File Transfer.