No anomalies have been detected in our logs. The Drive service has shown stability in the last hour and is fully operational for all users.
Posted Dec 11, 2025 - 11:47 UTC
Monitoring
An internal system that certain Drive features rely on was briefly unavailable after an update. This led to certain Drive features becoming unavailable until our systems came back online.
Our logs indicate that all services are now back up and operational, and we will continue monitoring over the course of the next hour.
Posted Dec 11, 2025 - 10:35 UTC
Update
Drive tasks configured with integrations to SharePoint are not functioning as expected. Our development team is actively investigating the root cause and working to restore full functionality as soon as possible.
We will continue to provide updates on this page as more information becomes available.
Posted Dec 11, 2025 - 10:22 UTC
Investigating
We are currently investigating an issue pertaining to Dualog Drive, where the Drive page on the Dualog Portal is unresponsive for some customers. We are still currently investigating the scope and impact, and will update this page and service status once more information presents itself.