Issues with email delivery
Incident Report for Dualog
Resolved
Our dev team has fixed the issue, and this incident has now been resolved.
Posted Jan 19, 2024 - 09:02 UTC
Investigating
We are currently experiencing issues with our mail service. Users may experience problems with sending emails from vessels. Our developers are investigating this, and we will keep you updated through this page.
Posted Jan 19, 2024 - 08:31 UTC
This incident affected: Email and Automatic File Transfer.