Dualog Service Interruption on 4 June 2025

Incident Report for Dualog

Postmortem

Post-Incident Report – Dualog Service Interruption on 4 June 2025

Incident Date: 4 June 2025
Duration: 08:35 to 11:40 UTC
Affected Services: Dualog Drive, Mail, and Portal
Status: Resolved

Summary

On the morning of 4 June 2025, several Dualog services were disrupted due to an unplanned incident at our data center provider. The disruption impacted the availability of our customer portal, the performance of our email services, and the ability of Dualog Drive to send and receive files. While services were gradually restored within a few hours, a subset of Dualog Drive installations continued to experience issues with delayed or stuck file transfers beyond the initial downtime window.

Timeline of Key Events

Root Cause

Our hosting partner was in the process of upgrading their infrastructure. During this activity, they performed a disk cleanup operation on shared storage systems. A misconfigured setting during this process introduced unintended disk I/O throttling, leading to service degradation and temporary failures.
Additionally, within our own infrastructure, a Dualog Drive database setting prioritized availability over consistency. This contributed to residual synchronization issues even after services were restored.

Impact

  • Dualog Drive was partially unavailable for approximately 90 minutes and experienced follow-up issues on some vessels due to corrupted sync states. In a few cases, this led to lost files, which had to be manually resent by the sender.
  • Dualog Mail services were intermittently unstable.
  • The Dualog Portal used for monitoring and configuration experienced degraded performance during most of the incident.
  • Other services remained unaffected.

Resolution & Recovery

  • A fix was deployed at the infrastructure level by our provider to eliminate the I/O throttling configuration and improve cleanup testing procedures.
  • A new version of Dualog Drive was released to recover from corrupted sync states. This patch is now available and was applied to affected installations.
  • Support teams have actively worked with customers to resolve residual file transfers and update installations. Affected customers were contacted directly with relevant file details and guidance for recovery.

Data Integrity

We have no indication of data leakage or unauthorized access.

Preventive Measures

We are committed to ensuring this does not happen again. As part of our long-term mitigation:

  • We are updating internal database settings to prioritize consistency in all clustered deployments.
  • We are revising error handling in Dualog Drive to better manage unexpected states from backend systems.
  • Our provider has committed to stricter safeguards when performing maintenance on shared infrastructure.

Final Note

At Dualog, operational reliability is a cornerstone of our service, and we treat incidents like these with the utmost seriousness. We regret the inconvenience this incident may have caused and remain committed to providing a resilient and transparent service experience.
We appreciate your patience and trust as we work to reinforce the resilience of our platform.

Posted Jun 20, 2025 - 07:17 UTC

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 13:40 UTC

Update

All services are now operational. We will continue monitoring for any unexpected behavior.
Posted Jun 04, 2025 - 11:58 UTC

Monitoring

All Link services are operational and have been reported to be stable. Email services may experience some slowness and degraded performance.

We will continue monitoring for service stability.
Posted Jun 04, 2025 - 11:46 UTC

Identified

Our data center provider has notified us of VMware issues on their end that are impacting their customers. Investigative work is currently being carried out on their end, and we are maintaining a close dialogue to assess performance.

Dualog services are slowly coming back online, but performance may not be fully stable. We are monitoring the situation and will return with more updates.
Posted Jun 04, 2025 - 11:13 UTC

Update

We are continuing to investigate this issue.
Posted Jun 04, 2025 - 10:48 UTC

Update

We have identified further impact on service functionality, where services running on the Dualog Link platform have been affected. Customers using the services below may temporarily face issues while we work at getting all systems back up and running.

We will notify any updates here on the statuspage.
Posted Jun 04, 2025 - 10:20 UTC

Investigating

The Dualog Portal is temporarily down, and our infrastructure team is investigating this. Users logging into webmail from shore may also face issues for the time being.

We will keep you updated on any further information shortly.
Posted Jun 04, 2025 - 10:06 UTC
This incident affected: Dualog Portal (apps.dualog.com), Email and Automatic File Transfer, Drive, Endpoint, Protect, and Fetch.