Mail routing issue between Dualog mail server and Office 365 recipients
Incident Report for Dualog
Resolved
The incident has now been resolved.
Posted Apr 04, 2022 - 03:04 UTC
Investigating
We are currently experiencing issues routing email to some Office 365 accounts. We are working on identifying the issue.
Posted Apr 03, 2022 - 20:45 UTC
This incident affected: Email and Automatic File Transfer.