Drive: Degraded performance

Incident Report for Dualog

Resolved

The issue has been resolved and traffic flow has resumed normally.
Posted Jun 05, 2025 - 18:36 UTC

Monitoring

The causes of the ongoing issue have been identified, and numerous fixes have been applied.
The situation is currently improving and under heavy monitoring.
Posted Jun 05, 2025 - 15:22 UTC

Identified

We are noticing some destinations in Dualog Drive that are stuck, and are releasing a client patch to fix this issue.
Posted Jun 05, 2025 - 10:49 UTC
This incident affected: Drive.