Degraded performance: Connectivity and email services
Incident Report for Dualog
Resolved
The airtime provider has informed us that a recent software update on their networks caused issues that impacted customers. A fix has been implemented on their end, and this incident is now resolved.
Posted Jul 17, 2024 - 18:23 UTC
Monitoring
We have notified the airtime provider of the symptoms faced on the affected vessels. If your vessels are experiencing connectivity issues, please contact support@dualog.com so we can assist with a temporary solution.
Posted Jul 17, 2024 - 18:06 UTC
Identified
Our investigations show that all reported issues are isolated to vessels connecting via a certain airtime provider. We have reason to believe that traffic is being throttled, and urge impacted customers to contact their airtime provider to resolve this issue.

In the meantime, our support team has a temporary workaround to ensure connectivitiy onboard. Please get in touch at support@dualog.com for assistance.
Posted Jul 17, 2024 - 13:57 UTC
Investigating
We are noticing issues that may impact connectivity and email transfers onboard certain vessels. We are currently investigating this, and will update the statuspage when more information is available.
Posted Jul 17, 2024 - 12:42 UTC
This incident affected: Email and Automatic File Transfer.