Temporary Disruption to Support Phone Line

Incident Report for Dualog

Resolved

All telephony services have been fully restored and are operating normally.
Posted Feb 12, 2026 - 13:09 UTC

Identified

We are currently experiencing issues with our support phone line due to an outage with our telephony provider. Our services remain fully operational and are not affected by this issue.

In the meantime, please contact our Support team via email at support@dualog.com.

We are working with the provider to resolve the issue and will provide updates as soon as more information becomes available.
Posted Feb 12, 2026 - 11:51 UTC
This incident affected: Support Services.