[Webmail] Partial Outage
Incident Report for Dualog
Resolved
This incident has been resolved.
Posted Oct 23, 2023 - 09:20 UTC
Investigating
We are experiencing some issues with webmail.dualog.com. Our technicians are currently investigating the issue and further updates will be given when more information is available.
Posted Oct 23, 2023 - 08:33 UTC
This incident affected: Email and Automatic File Transfer.