Dualog Email Incident

Incident Report for Dualog

Resolved

Our monitoring has concluded that the incident was resolved by the implemented fix.
Posted May 25, 2026 - 12:59 UTC

Monitoring

A fix has been implemented and we are monitoring the outcome.
Posted May 25, 2026 - 10:11 UTC

Investigating

We have received reports about an issue impacting email traffic, and are currently investigating.
Posted May 25, 2026 - 10:00 UTC
This incident affected: Email and Automatic File Transfer.