[Dualog Drive] Degraded Performance
Incident Report for Dualog
Resolved
This incident is now resolved. All services are fully operational.
Posted Nov 13, 2023 - 14:46 UTC
Investigating
We are currently experiencing some technical issues on our Link Platform. Users may experience degraded performance when transferring files via Dualog Drive.

We are currently investigating - further updates will be given on the status page when more information is available.
Posted Nov 13, 2023 - 14:24 UTC
This incident affected: Dualog Drive.