Support Line Disruption

Incident Report for Dualog

Resolved

Our telecommunications provider has confirmed this incident has been resolved. All Dualog Support lines are fully operational.
Posted Mar 05, 2025 - 21:12 UTC

Identified

Our support line +47 776 21 911 is currently unavailable due to infrastructure issues with our telecommunications provider. Customers may still reach us via support@dualog.com or our Singaporean support number +65 622 21 911 for technical assistance.
Posted Mar 05, 2025 - 14:17 UTC
This incident affected: Support Services.