Degraded Starlink Connectivity

Incident Report for Dualog

Resolved

Our reports indicate that Starlink has resolved the issue.
Posted Mar 12, 2026 - 12:36 UTC

Investigating

We have recieved reports that some vessels are experiencing connectivity issues with Starlink. We will update this page once we have more information.
Posted Mar 12, 2026 - 10:07 UTC
This incident affected: External Service.