webmail.dualog.com login unavailable
Incident Report for Dualog
Resolved
The incident has been resolved.
webmail.dualog.com is confirmed working.
Posted Mar 13, 2024 - 13:52 UTC
Identified
The issue has been identified and it is being fixed.
Posted Mar 13, 2024 - 13:50 UTC
Investigating
The cloud webmail portal - webmail.dualog.com is currently not accepting any login.
Please note that this incident is not affecting mail on board the vessels.
The incident is being investigated and we will update it accordingly.
Posted Mar 13, 2024 - 13:36 UTC